Incident affecting timers LogMessage in ODC Portal

Incident Report for OutSystems

Postmortem

A platform-wide issue was identified where log messages generated within successful Timers were inconsistently or completely missing from the monitoring interface.
The root cause was a technical race condition during a critical component startup, which prevented logs from reaching the central logging system. Engineering team developed and deployed an update that resolved the issue, and extensive monitoring has confirmed the platform is now stable, with all Timer-originated log entries appearing correctly.

Posted Nov 19, 2025 - 09:05 UTC

Resolved

We have successfully deployed a fix for the LogMessage issue that affected timers in the Europe (Frankfurt) and Asia Pacific (Tokyo) regions. Our monitoring confirms that the issue is fully resolved and all services are operating normally. Thank you for your patience.
Posted Nov 17, 2025 - 17:45 UTC

Monitoring

We have identified the cause of the issue. The fix is now in deployment, and a full resolution is expected by Tuesday, November 18th. We will continue monitoring this situation to ensure full recovery.
Posted Nov 14, 2025 - 16:54 UTC

Identified

We have identified the cause of this issue. Our team is actively working on implementing a solution and we will provide an update once more details are available.
Posted Nov 14, 2025 - 14:44 UTC

Investigating

We are aware of an issue concerning LogMessage entries not appearing in the ODC Portal when executed inside timers. This is affecting Europe (Frankfurt) and Asia Pacific (Tokyo) regions. Our team is currently investigating its cause. We will provide an update as soon as more details are available.
Posted Nov 14, 2025 - 14:26 UTC
This incident affected: ODC - Platform and Portal (Europe / Frankfurt, Asia Pacific / Tokyo).