Incident affecting sign-in and application access on ODC

Incident Report for OutSystems

Postmortem

On August 10th, 2026, from 20:31 to 22:19 UTC, users in the South America / São Paulo region experienced errors when signing in to ODC. This prevented affected users from accessing their Production applications and also affected the ODC Portal and ODC Studio.

The issue was detected through customer reports and monitoring. Our investigation found that a fault in an internal caching component of our identity service was preventing it from issuing sign-in tokens, even though the service otherwise appeared to be running normally.

To restore service, our team restarted the affected identity service, which cleared the fault and allowed token issuance to resume. We confirmed with affected customers that sign-in and application access had returned to normal before closing the incident.

We have identified additional monitoring and preventive improvements for this component and are prioritising their rollout to help reduce the risk of similar issues recurring. We apologise for any disruption caused and thank you for your patience.

Posted Aug 12, 2026 - 06:47 UTC

Resolved

The incident affecting sign-in and application access in the South America / São Paulo region has been resolved. All services are now fully operational.
Posted Aug 11, 2026 - 07:54 UTC

Monitoring

A fix has been applied to address the issue affecting sign-in and application access for ODC in the South America / São Paulo region. Initial checks with affected users confirm that sign-in and application access have been restored.

We are now monitoring the platform to ensure full recovery across all affected services, including ODC Studio and the ODC Portal.
Posted Aug 10, 2026 - 22:23 UTC

Investigating

We are aware of an issue affecting ODC in the South America / São Paulo region. Users may be unable to sign in, and applications in production may be unavailable to end users. Access to ODC Studio and the ODC Portal may also be affected.

Our team is currently investigating the cause and will provide updates as more information becomes available.
Posted Aug 10, 2026 - 20:48 UTC
This incident affected: ODC - Customer Apps & Data (South America / São Paulo), ODC - Platform and Portal (South America / São Paulo), and ODC - Identity & Access Management (South America / São Paulo).