Recurrence of the incident affecting Personal Editions on ODC in several regions

Incident Report for OutSystems

Postmortem

On the 20th of July 2026, there was an issue with the wake-up functionality affecting Personal Editions. This occurred in all three regions (US East, Europe and Asia Pacific).
Users were unable to wake up their environments from hibernation. When attempting to wake up the environments, they either remained in hibernation or moved to a "waking up" state indefinitely, preventing access to applications.
This was caused by an issue in how our backend systems processed environment status updates. Due to messages being processed out of order, some environments' internal state was incorrectly reverted to 'hibernated' after they had already woken up successfully, even though the environment itself remained accessible on the backend. This caused the ODC Portal to keep showing an inaccurate 'hibernated' or 'waking up' status, and repeated wake-up attempts did not resolve it since the underlying state kept getting overwritten.
We identified the root cause on the 21st of July and deployed a code fix to correct the state synchronization. The fix started to be rolled out to all regions on 22nd of July and completed by the 23rd of July. All affected environments were woken up successfully.
We are implementing additional state verification checks to ensure the ODC Portal and backend systems remain in sync. A full technical review is underway to identify similar synchronization gaps across other features.
We apologize for any disruption caused and thank you for your patience.

Posted Jul 23, 2026 - 13:06 UTC

Resolved

We have successfully resolved the issue affecting ODC Personal Editions across multiple regions. Environments that were unable to wake from hibernation are now fully operational.
All known affected customers have now been restored to service, and we confirm that services are operating as expected across all regions.
We apologize for any disruption caused and thank you for your patience.
Posted Jul 23, 2026 - 09:06 UTC

Update

Our team has deployed an automated fix to systematically restore affected Personal Edition environments. Recovery is now in progress across all regions. The fix should handle recovery automatically. We are actively monitoring restoration progress and will confirm full resolution once the process completes. We will provide updates as more information becomes available.
Posted Jul 21, 2026 - 22:36 UTC

Update

We have identified a temporary workaround that may help affected users restore access while the fix continues to roll out: publishing an application in your Personal Edition may temporarily help wake it up.
If you are currently unable to wake your environment, please try publishing an application. We will provide further updates as the deployment progresses.
Posted Jul 21, 2026 - 09:31 UTC

Identified

Our team has identified a resolution and is actively rolling out a fix. During the deployment, symptoms may persist while the fix reaches all affected regions. We will provide updates as more information becomes available.
Posted Jul 21, 2026 - 07:16 UTC

Investigating

We are aware of a recurrence of issues affecting Personal Editions on ODC in several regions (US East, Europe, and Asia Pacific).
Following the resolution we announced yesterday, some users have reported that they are still experiencing difficulties waking their environments from hibernation.
Our team is actively investigating this recurrence and working to identify the cause. We will provide updates as more information becomes available.
Posted Jul 21, 2026 - 02:13 UTC
This incident affected: OutSystems Personal Edition (Customer Apps & Data).