502 Error Affecting ODC Portal Access Globally

Incident Report for OutSystems

Postmortem

On July 30, 2026, between 15:19 and 15:59 UTC, customers in multiple regions experienced an outage affecting access to the OutSystems ODC Portal, preventing them from logging in or accessing their development environments. The incident was caused by the addition of a custom header, which prevented requests from reaching the portal. Following the code change rollback, service was restored by 15:59 UTC. To prevent similar incidents in the future, we are implementing additional automated testing to validate configuration changes before they are deployed to production and conducting a comprehensive review of our code review and testing procedures to catch such issues earlier in the development process. We appreciate your patience during this incident and apologize for any disruption to your work.

Posted Aug 04, 2026 - 15:32 UTC

Resolved

The 502 errors affecting the ODC Portal globally have been resolved. Between 15:19 and 15:59 UTC on July 30th, users experienced connectivity issues caused by a recent configuration change affecting header validation. The change has been reverted, and access to the ODC Portal has been fully restored. All services are now operating as expected. We apologise for any disruption caused and thank you for your patience.
Posted Jul 30, 2026 - 18:39 UTC
This incident affected: ODC - Platform and Portal (US East / Virginia, Canada / Central, South America / São Paulo, Europe / Ireland, Europe / London, Europe / Frankfurt, Africa / Cape Town, Israel / Tel Aviv, Middle East / UAE, Asia Pacific / Mumbai, Asia Pacific / Singapore, Asia Pacific / Jakarta, Asia Pacific / Hong Kong, Asia Pacific / Seoul, Asia Pacific / Tokyo, Asia Pacific / Sydney).