Issue with delayed timer execution in ODC

Incident Report for OutSystems

Postmortem

On August 26th, between 05:16 UTC and 16:26 UTC, some ODC users experienced delays in the execution of timers. Affected timers remained pending instead of running as scheduled, and subsequent runs did not start. Users in US East / Virginia and Asia Pacific / Singapore were affected. Applications themselves remained available throughout.

The issue was caused by a recent platform update that changed how a timer's status is recorded once it has run. Under that update, a timer whose status needed to be recorded more than once in sequence failed to update correctly, leaving it pending and blocking later scheduled executions. To restore service, our team returned the affected part of the platform to its previous version, which stopped the issue recurring for affected users. A permanent correction was then developed, validated and deployed across the platform, and we confirmed that timers were executing normally before closing the incident.

We are reviewing our monitoring of timer execution so that issues of this kind are detected automatically rather than through customer reports. We apologise for any disruption caused and thank you for your patience.

Posted Aug 27, 2026 - 04:57 UTC

Resolved

This incident has been resolved. The issue was caused by a recent platform update that could prevent a timer's status from being recorded correctly after it ran, leaving it in a pending state. Our team has corrected this and confirmed that timers are executing as expected across the affected regions.
We apologise for any disruption caused and thank you for your patience.
Posted Aug 26, 2026 - 16:33 UTC

Monitoring

A solution has been applied to resolve this issue. We will continue monitoring this situation to ensure full recovery. We will provide updates as more information becomes available.
Posted Aug 26, 2026 - 06:56 UTC

Investigating

We are currently investigating an issue that may cause delays in the execution of timers for some applications. Some timers may remain pending longer than expected. We will provide an update as soon as we have more information.
Posted Aug 26, 2026 - 05:16 UTC
This incident affected: ODC - Customer Apps & Data (US East / Virginia, Asia Pacific / Singapore).